注册
DMDRS搭建、使用DRS实现PG到达梦的数据同步
专栏/培训园地/ 文章详情 /

DMDRS搭建、使用DRS实现PG到达梦的数据同步

Владимир Антон 2026/09/18 71 0 0
摘要

DMDRS搭建、使用DRS实现PG到达梦的数据同步

Table of Contents


大家想学习达梦数据库或者解决报错问题,可以去达梦数据库社区https://eco.dameng.com

一、产品介绍

达梦数据复制软件(简称 DMDRS)是一种用于同构数据库、异构数据库以及各种数据管理系统之间的数据复制软件。

数据迁移是指将源数据库的全量数据一次性迁移到目标数据库,适用于同构或异构数据库之间的数据迁移,一般用于源数据库在静态的情况下进行数据迁移的场景。

数据同步是指通过全量数据装载和增量数据同步的组合来实现数据复制功能,实现源数据库在动态的场景下和目标数据库数据的一致性,适用于同构或异构数据库之间的数据实时同步。DRS会先进行全量同步,增量的数据暂时先存在缓存上,等全量跑完后在启动增量

image.png

主备同步是指DMDRS 主节点服务承担同步功能,DMDRS 备节点服务处于等待就绪状态,持续同步主节点服务的环境。当 DMDRS 主节点服务所在的数据库节点故障后,DMDRS 备节点服务会自动成为主节点,避免同步中断。

image.png

根据实际的应用场景完成 DMDRS 的安装后,用户可以通过达梦数据融合管理平台(DMDFM)搭建 DMDRS 服务,也可以直接在服务器上搭建 DMDRS 服务。

无侵入性的增量数据捕获

DMDRS采用基于数据库日志的数据复制技术,通过实时解析数据库日志捕获增量操 作数据,无需在源数据库上创建相关对象,对源数据系统无侵入性。DMDRS采用高效的 日志扫描和读取算法,多线程并行实时捕获增量操作,并通过自主研发的数据库日志解析 引擎,实现高效的数据实时复制,无需依赖第三方的日志解析工具

装载与同步并行执行技术

装载与同步并行执行技术通过在目标端创建三种执行分组实现,分别是装载分组、等 待分组和执行分组。装载分组用于缓存装载数据并执行入库;等待分组用于缓存需要等待 提交的事务数据;执行分组用于缓存可立即执行的事务数据并执行入库。通过等待分组进 行事务数据状态切换,实现全量和增量数据的无缝衔接,提高数据复制的整体效率。

产品架构

image.png

Manager:统筹管理调度所有模块运行

CPT:源端抓取全量与增量数据

DSS:缓存转发、分发同步数据

EXEC:目标端执行数据入库同步

二、安装部署

DMDRS 服务 内存要求 磁盘要求
源端 DMDRS 8-16GB 至少 100GB
目标端 DMDRS 8-16GB 至少 100GB

2.1 用户以及目录

为避免 DMDRS 在访问数据库文件时权限不足、环境变量错误等问题,建议源端与目的端在进行安装时选择对应的数据库的安装用户安装。例如:源端 Oracle 数据库安装用户为 oracle,则源 DMDRS 就使用 oracle 用户进行安装;目的端 DM 数据库安装用户为 dmdba,则目的 DMDRS 就使用 dmdba 用户进行安装。

# DMDRS 默认安装目录在 home 目录下,用户可根据需要是否自定义安装目录 [root@localhost /]# mkdir -p /data/dmdrs5 [root@localhost /]# chown dmdba:dinstall -R /data/dmdrs5/ [root@localhost /]# chmod -R 755 /data/dmdrs5/

上传 DMDRS 安装包到 opt 目录,并修改权限,本文为以安装 dmdrs_v5.0.0.03*** 为例。

cd /opt/drs [root@localhost opt]# chown dmdba:dinstall dmdrs_rev176693_x86_rh6_64***.bin [root@localhost opt]# chmod -R 755 dmdrs_rev176693_x86_rh6_64***.bin

2.2 DRS软件安装

安装软件

如果/tmp目录不能保证3GB的存储空间,用户可以扩展/tmp目录存

储空间或者通过设置环境变量DMDRS_INSTALL_TMPDIR指定安装

程序的临时目录。

当Linux(Unix)操作系统没有图形化界面时,用户可以使用命令行的方式安装

DMDRS。在终端进入安装程序所在文件夹,执行以下命令进行命令行安装。

[dmdba@localhost drs]$ ./dmdrs_rev218265_x86_rh6_64_20260409.bin -i Extract install files.........

数据库驱动路径配置:

DMDRS 会自动选择已安装好的 dm 数据库 bin 目录作为数据库动态库路径,用户也可自定义动态库路径,本文指定动态库路径为:/home/dmdba/dmdbms/bin

[dmdba@localhost drs]$ ./dmdrs_rev218265_x86_rh6_64_20260409.bin -i Extract install files......... Please select the installer's language (C/c:Simplified Chinese, H/h:Hong Kong Tr aditional Chinese, E/e:English)[E/e]:c -----------欢迎使用达梦数据复制软件安装工具----------- 输入[exit]可退出安装。 -----------安装目录----------- 指定安装目录[/home/dmdba/dmdrs5]:/data/dmdrs5 该路径不为空,是否继续安装?(Y/y or N/n)[N/n]:y -----------安装组件----------- 请选择需要安装的组件 1.安装达梦数据融合管理平台 2.安装代理 请选择安装组件数字序号(使用空格间隔):1 2 选择的组件有: 1.安装达梦数据融合管理平台 2.安装代理 确认?[Y/y(确认选择) or N/n(重新选择)]:y -----------许可证文件----------- 1.免费试用达梦数据复制软件(必须在试用期范围内使用,反复安装无效,使用时间为3个月) 2.使用许可证文件 指定许可证文件(1,2)[1]:1 免费试用许可证文件限制信息如下: 有效日期:1970-04-01 版本类型:试用版 许可证编号:dm66n367 授权顾客名称:DEVELOP USER 当前选择为免费试用,是否继续安装?[Y/y or N/n]:y -----------配置----------- 数据库驱动路径配置 -数据库驱动路径[]:/home/dmdba/dmdbms/bin 注意:代理配置IP不允许设置成127.0.0.1! 代理配置-代理IP(192.168.157.140): 请手动输入代理ip! 代理配置-代理IP(192.168.157.140):192.168.157.140 代理配置-代理端口[19345]: 达梦数据融合管理平台配置-管理平台端口[8080]: 注意:密码必须至少8个字符,并且满足以下条件中的任意[两项]:数字、大写字母、小写字母、特殊字符(如!@#$%^&*等)。 达梦数据融合管理平台配置-管理平台密码: 达梦数据融合管理平台配置-管理平台确认密码: 密码与确认密码不一致,请重新输入。 注意:密码必须至少8个字符,并且满足以下条件中的任意[两项]:数字、大写字母、小写 字母、特殊字符(如!@#$%^&*等)。 达梦数据融合管理平台配置-管理平台密码: 达梦数据融合管理平台配置-管理平台确认密码: 密码与确认密码不一致,请重新输入。 注意:密码必须至少8个字符,并且满足以下条件中的任意[两项]:数字、大写字母、小写 字母、特殊字符(如!@#$%^&*等)。 达梦数据融合管理平台配置-管理平台密码: 达梦数据融合管理平台配置-管理平台确认密码: 是否使用外置库(0:不使用 1:使用 )[0]:1 外置库配置-数据库服务IP:127.0.0.1 外置库配置-数据库端口[15236]:5236 外置库配置-用户名[SYSDBA]: 外置库配置-密码[]: -----------安装小结----------- 安装目录:[/data/dmdrs5] 数据库驱动路径:[/home/dmdba/dmdbms/bin] 代理IP:[192.168.157.140] 代理端口:[19345] 达梦数据融合管理平台IP:[127.0.0.1] 达梦数据融合管理平台端口:[8080] 外置库信息: 数据库IP:[127.0.0.1] 数据库端口:[5236] 用户名:[SYSDBA] 密码:[******] 所需磁盘空间/可用磁盘空间:[1,768 MB/9,306 MB] 确认安装?[Y/y or N/n]:y -----------安装中----------- server 正在安装 ... server 安装完成. default 正在安装 ... default 安装完成. agent 正在安装 ... agent 安装完成. web 正在安装 ... web 安装完成. doc 正在安装 ... doc 安装完成. 安装成功 -----------系统服务----------- 达梦数据融合管理平台服务设置 1.注册系统服务 2.不注册系统服务 启动方式(1,2)[2]:1 正在创建达梦数据融合管理平台服务.... 达梦数据融合管理平台代理服务设置 1.注册系统服务 2.不注册系统服务 启动方式(1,2)[2]:1 正在创建达梦数据融合管理平台代理服务.... 以下配置脚本需要以"root"用户的身份运行. /data/dmdrs5/scripts/root/root_installer.sh 是否已执行shell脚本?(Y/y or N/n)[Y/y]:y -----------安装总结----------- 达梦数据复制软件V5安装完成 地址:http://127.0.0.1:8080 用户名/密码:admin/****** 更多安装信息,请查看安装日志文件:/data/dmdrs5/log/install.log [dmdba@localhost drs]$ exit 注销 [root@localhost drs]# /data/dmdrs5/scripts/root/root_installer.sh 创建DfmWebService服务 Created symlink /etc/systemd/system/multi-user.target.wants/DfmWebService.service → /usr/lib/systemd/system/DfmWebService.service. 创建服务(DfmWebService)完成 创建DfmAgentService服务 Created symlink /etc/systemd/system/multi-user.target.wants/DfmAgentService.service → /usr/lib/systemd/system/DfmAgentService.service. 创建服务(DfmAgentService)完成 启动DfmWebService服务 启动DfmAgentService服务 [root@localhost drs]#

服务的启动停止

# 内置数据库服务 # 查看状态 /home/dmdrs/dmdrs5/db/bin/DmServiceDFDB status # 启动服务 /home/dmdrs/dmdrs5/db/bin/DmServiceDFDB start # 停止服务 /home/dmdrs/dmdrs5/db/bin/DmServiceDFDB stop # 达梦数据融合管理平台服务 # 查看状态 /home/dmdrs/dmdrs5/web/DfmWebService status # 启动服务 /home/dmdrs/dmdrs/dmdrs5/web/DfmWebService start # 停止服务 /home/dmdrs/dmdrs5/web/DfmWebService stop # 达梦数据融合管理平台代理服务 # 查看状态 /home/dmdrs/dmdrs5/agent/DfmAgentService status # 启动服务 /home/dmdrs/dmdrs5/agent/DfmAgentService start # 停止服务 /home/dmdrs/dmdrs5/agent/DfmAgentService stop

2.3 登录DFM

image.png

2.4 准备测试环境

达梦数据库创建模式

CREATE USER """DRS_TEST""" IDENTIFIED BY "Damen_123" DEFAULT TABLESPACE "MAIN"; GRANT "DBA" TO """DRS_TEST"""; GRANT "RESOURCE" TO """DRS_TEST"""; GRANT "PUBLIC" TO """DRS_TEST"""; GRANT "VTI" TO """DRS_TEST"""; GRANT "SOI" TO """DRS_TEST"""; GRANT CREATE SESSION TO """DRS_TEST"""; CREATE SCHEMA "DRS_TEST" AUTHORIZATION "SYSDBA"; CALL SP_SET_SCHEMA_DESC('DRS_TEST', 'DRS数据同步测试使用'); SQL> set schema DRS_TEST; 操作已执行 已用时间: 1.989(毫秒). 执行号:0. SQL>

Oracle数据库创建用户

#创建用户 -- 创建管理员用户 DBA_ADMIN CREATE USER DBA_ADMIN IDENTIFIED BY "Admin@123"; -- 授予DBA管理员权限、数据泵权限 GRANT DBA, EXP_FULL_DATABASE, IMP_FULL_DATABASE TO DBA_ADMIN; -- 创建用户(密码:Oracle_123) CREATE USER USER01 IDENTIFIED BY Oracle_123; -- 授予基本权限(必须) GRANT CONNECT, RESOURCE TO USER01; # 切换模式 ALTER SESSION SET CURRENT_SCHEMA = TEST_EXBASE; select OWNER,table_name from all_tables where OWNER like 'TEST_EXBAS%'; select * from STUDENT fetch first 3 rows only;

PG数据库创建用户

postgres=# create user dba_admin with password 'Admin@123'; CREATE ROLE postgres=# \dn List of schemas Name | Owner --------+------------------- public | pg_database_owner (1 row) postgres=# create database dm_drs_test owner dba_admin; CREATE DATABASE postgres=# \c dm_drs_test You are now connected to database "dm_drs_test" as user "fbase". dm_drs_test=# \d Did not find any relations. dm_drs_test=# postgres=# alter user dba_admin with superuser ; ALTER ROLE postgres=# \du List of roles Role name | Attributes | Member of -----------+------------------------------------------------------------+----------- dba_admin | Superuser | {} fbase | Superuser, Create role, Create DB, Replication, Bypass RLS | {} -- 数据库开启归档 postgres=# show archive_command ; archive_command ------------------------------ cp %p /data/fbase/archive/%f (1 row) -- PostgreSQL 12/13版本使用“ddl_sql_pg12.sql”脚本创建触发器和辅助表。

三、测试案例

3.1 DMDRS工具PostgreSQL -> DM8单向数据同步

业务此场景规划

image.png

创建数据源
image.png

远程安装DFM代理、DRS同步工具

部署代理

image.png

# 启动代理 sh startup-agent.sh

部署drs

image.png

配置同步链路
image.png

启动实例

drs启动报错

2026-05-19 14:17:43 MGR[ERROR]: DRS-3037 未找到动态库文件 path: libdrcpg.so, code: 2 msg:libodbc.so.1: cannot open shared object file: No such file or directory 2026-05-19 14:17:43 MGR[ERROR]: DRS-3010 模块启动失败 Please press Enter to exit

乱码的时候使用命令来查看就不会出现乱码了

[fbase@node1 log]$ cat drs_202605.log | iconv -f GBK -t UTF-8 2026-05-19 14:15:53 MGR[WARN]: 未能检测到dmdrs.key文件,即将体验免费版 2026-05-19 14:15:53 MGR[INFO]: DRS start up, current version: V5.2.5.4-Build(2026.04.08-218265_trunc_sp2)_64 (X86)(The beta)(Enterprise Edition) 2026-05-19 14:15:53 MGR[WARN]: mem_size参数配置过大,超过系统剩余内存大小 mem_size: 16G, total_free_size: 5G 2026-05-19 14:15:53 MGR[WARN]: 无key状态下DRS性能受限制 parse_thr: 1 2026-05-19 14:15:53 MGR[ERROR]: DRS-3037 未找到动态库文件 path: libdrcpg.so, code: 2 msg:libodbc.so.1: cannot open shared object file: No such file or directory 2026-05-19 14:15:53 MGR[ERROR]: DRS-3010 模块启动失败 Please press Enter to exit 2026-05-19 14:17:43 MGR[WARN]: 未能检测到dmdrs.key文件,即将体验免费版 2026-05-19 14:17:43 MGR[INFO]: DRS start up, current version: V5.2.5.4-Build(2026.04.08-218265_trunc_sp2)_64 (X86)(The beta)(Enterprise Edition) 2026-05-19 14:17:43 MGR[WARN]: mem_size参数配置过大,超过系统剩余内存大小 mem_size: 16G, total_free_size: 5G 2026-05-19 14:17:43 MGR[WARN]: 无key状态下DRS性能受限制 parse_thr: 1 2026-05-19 14:17:43 MGR[ERROR]: DRS-3037 未找到动态库文件 path: libdrcpg.so, code: 2 msg:libodbc.so.1: cannot open shared object file: No such file or directory 2026-05-19 14:17:43 MGR[ERROR]: DRS-3010 模块启动失败 Please press Enter to exit

可以看到这个动态库它有个东西没有找到

[fbase@node1 instance1]$ pwd /home/fbase/agent/INST_DRS/instance1 [fbase@node1 instance1]$ ldd libdrcpg.so linux-vdso.so.1 (0x00007ffd25b8b000) libc.so.6 => /usr/lib64/libc.so.6 (0x00007fb31a2d7000) libm.so.6 => /usr/lib64/libm.so.6 (0x00007fb31a154000) librt.so.1 => /usr/lib64/librt.so.1 (0x00007fb31a149000) libpthread.so.0 => /usr/lib64/libpthread.so.0 (0x00007fb31a128000) libdl.so.2 => /usr/lib64/libdl.so.2 (0x00007fb31a123000) libdrpub.so => ./libdrpub.so (0x00007fb31884d000) libdrnet.so => ./libdrnet.so (0x00007fb318632000) libdrcache.so => ./libdrcache.so (0x00007fb3183cc000) libdrxml.so => ./libdrxml.so (0x00007fb3181bb000) /lib64/ld-linux-x86-64.so.2 (0x00007fb31a94f000) libodbc.so.1 => not found [fbase@node1 instance1]$ [root@node1 install]# find / -name "libodbc.so" /usr/lib64/libodbc.so [root@node1 install]# ln -s /usr/lib64/libodbc.so /usr/lib64/libodbc.so.1 [fbase@node1 instance1]$ ldd libdrcpg.so linux-vdso.so.1 (0x00007ffe1d6f4000) libc.so.6 => /usr/lib64/libc.so.6 (0x00007f9c5d2e7000) libm.so.6 => /usr/lib64/libm.so.6 (0x00007f9c5d164000) librt.so.1 => /usr/lib64/librt.so.1 (0x00007f9c5d159000) libpthread.so.0 => /usr/lib64/libpthread.so.0 (0x00007f9c5d138000) libdl.so.2 => /usr/lib64/libdl.so.2 (0x00007f9c5d133000) libdrpub.so => ./libdrpub.so (0x00007f9c5b85d000) libdrnet.so => ./libdrnet.so (0x00007f9c5b642000) libdrcache.so => ./libdrcache.so (0x00007f9c5b3dc000) libdrxml.so => ./libdrxml.so (0x00007f9c5b1cb000) libodbc.so.1 => /lib64/libodbc.so.1 (0x00007f9c5b15a000) /lib64/ld-linux-x86-64.so.2 (0x00007f9c5d95f000) libltdl.so.7 => /usr/lib64/libltdl.so.7 (0x00007f9c5b14f000)

启动成功

[fbase@node1 instance1]$ sh DrsServiceinstance1 status DrsServiceinstance1 is stopped [fbase@node1 instance1]$ sh DrsServiceinstance1 start Starting DrsServiceinstance1: [ OK ] [fbase@node1 instance1]$ sh DrsServiceinstance1 status DrsServiceinstance1 (pid 91378) is running... [fbase@node1 instance1]$

CPT模块启动失败

2026-05-19 14:29:09 MGR[INFO]: SITEID: 1 NAME: instance1 MEMCHECK: 0 PORT: 5345 GROUP: 0 VERSION: 1 PATH: /home/fbase/agent/INST_DRS/instance1/drs.xml 2026-05-19 14:30:15 link1[ERROR]: DRS-5 数据库访问失败 Connection failed, conn_str: SERVER=192.168.157.141;DRIVER=PostgreSQL ANSI(x64);UID=dba_admin;PWD=******;DATABASE=dm_drs_test;PORT=8432;, msg:[unixODBC][Driver Manager]Can't open lib 'PostgreSQL ANSI(x64)' : file not found 2026-05-19 14:30:15 link1[ERROR]: DRS-5072 数据库连接异常 server[192.168.157.141:8432] 2026-05-19 14:30:15 MGR[ERROR]: DRS-5130 CPT模块未初始化 2026-05-19 14:31:00 MGR[ERROR]: DRS-5186 LD未初始化 2026-05-19 14:31:00 MGR[ERROR]: DRS-5186 LD未初始化 2026-05-19 14:31:00 link1[ERROR]: DRS-5 数据库访问失败 Connection failed, conn_str: SERVER=192.168.157.141;DRIVER=PostgreSQL ANSI(x64);UID=dba_admin;PWD=******;DATABASE=dm_drs_test;PORT=8432;, msg:[unixODBC][Driver Manager]Can't open lib 'PostgreSQL ANSI(x64)' : file not found

是因为在数据库中需要unixODBC组件

yum install -y unixODBC unixODBC-devel yum install -y postgresql-libs postgresql-devel # 下载odbc [fbase@node1 odbc]$ wget https://ftp.postgresql.org/pub/odbc/versions.old/src/psqlodbc-15.00.0000.tar.gz --2026-05-19 14:54:00-- https://ftp.postgresql.org/pub/odbc/versions.old/src/psqlodbc-15.00.0000.tar.gz Resolving ftp.postgresql.org (ftp.postgresql.org)... 146.75.47.52, 2a04:4e42:7b::820 Connecting to ftp.postgresql.org (ftp.postgresql.org)|146.75.47.52|:443... connected. HTTP request sent, awaiting response... 200 OK # 编译安装 ./configure --with-libpq=/usr/local/fbase/15.4/bin/pg_config --prefix=/home/fbase/odbc/install # 使用root编译 make && make install # 添加环境变量,在.bash_profile配置文件末尾增加ODBC驱动路径。 export LD_LIBRARY_PATH=<ODBC驱动路径>:$LD_LIBRARY_PATH # 查看odbc存放位置 [fbase@node1 log]$ odbc_config --version 2.3.7 [fbase@node1 log]$ odbc_config --odbcini /etc/odbc.ini [fbase@node1 log]$odbc_config --odbcinstini # 添加驱动 [root@node1 lib]# cat /etc/odbcinst.ini | head -n 10 # Example driver definitions # Driver from the postgresql-odbc package # Setup from the unixODBC package [PostgreSQL ANSI(x64)] Description = ODBC for PostgreSQL Driver = /home/fbase/odbc/install/lib/psqlodbcw.so Setup = /home/fbase/odbc/install/lib/psqlodbcw.so # 编辑unixODBC目录下的odbc.ini文件,在里面添加类似如下内容 [PGSQL-125] Description=DataSource for PG-125 Driver=PostgreSQL Database=postgres Servername=127.0.0.1 Port=8432 UserName=dba_admin Password=Admin@123 # 连接成功 [root@node1 ~]# isql -v PGSQL-125 +---------------------------------------+ | Connected! | | | | sql-statement | | help [tablename] | | quit | | | +---------------------------------------+ SQL>

再次启动

2026-05-19 16:16:28 link1[INFO]: db version: Fbase 15.4, base 1.8 on x86_64-pc-linux-gnu, compiled by gcc (GCC) 7.3.0, 64-bit 2026-05-19 16:16:28 link1[INFO]: PostgreSQL version is : 15.4 (150400) 2026-05-19 16:16:28 link1[INFO]: db: dm_drs_test, archived log path : /data/fbase/archive 2026-05-19 16:16:28 link1[INFO]: db: dm_drs_test, online log path : /data/fbase/fdata/pg_wal 2026-05-19 16:16:28 MGR[INFO]: 成功获取模块的起始SCN cpt name: link1, LSN: 55285792 2026-05-19 16:16:28 MGR[INFO]: 模块正在启动 module: link1 2026-05-19 16:16:28 link1[INFO]: siteid: 1, start lsn: 55285792 2026-05-19 16:16:28 link1[INFO]: 表字典加载完毕 dict num: 0, dict pool size: 0(MB) 2026-05-19 16:16:28 link1[INFO]: 表约束加载完毕 2026-05-19 16:16:28 link1[INFO]: 正在初始化系统表信息 2026-05-19 16:16:28 link1[INFO]: 正在初始化系统表列信息 2026-05-19 16:16:28 link1[INFO]: 正在初始化主键信息... 2026-05-19 16:16:28 link1[LD][INFO]: 保存字典信息完成 2026-05-19 16:16:28 link1[INFO]: 正在初始化系统表信息 2026-05-19 16:16:28 link1[INFO]: 正在初始化系统表列信息 2026-05-19 16:16:28 link1[INFO]: 正在初始化主键信息... 2026-05-19 16:16:28 link1[LD][INFO]: 开启表的全日志 database: dm_drs_test 2026-05-19 16:16:28 link1[LD][INFO]: 开启表的全日志 database: dm_drs_test, total replica identity enabled tables: 0 2026-05-19 16:16:28 link1[LD][INFO]: 保存字典信息完成 2026-05-19 16:16:28 link1[INFO]: DDL捕获方式 mode: 未开启DDL, unicode: TRUE, length in char: 0 2026-05-19 16:16:28 link1[INFO]: [link1] searching archive log in dir: /data/fbase/archive 2026-05-19 16:16:28 link1[INFO]: archive log file: 000000010000000000000001(0x001000000, 0x001FFFFFF) 2026-05-19 16:16:28 link1[INFO]: archive log file: 000000010000000000000002(0x002000000, 0x002FFFFFF) 2026-05-19 16:16:28 link1[CLEAR][INFO]: 线程启动 THR: CLEAR 2026-05-19 16:16:28 link1[INFO]: online log file: 000000010000000000000001(0x001000000, 0x001FFFFFF) 2026-05-19 16:16:28 link1[INFO]: online log file: 000000010000000000000002(0x002000000, 0x002FFFFFF) 2026-05-19 16:16:28 link1[INFO]: online log file: 000000010000000000000003(0x003000000, 0x003FFFFFF) 2026-05-19 16:16:28 link1[INFO]: [link1] Starting file located in: 000000010000000000000003(0x003000000, 0x0034B9820, 0x003FFFFFF) 2026-05-19 16:16:28 link1[INFO]: 日志文件切换 [dm_drs_test] Switch to the online log file: 000000010000000000000003(0x003000000, 0x003FFFFFF) 2026-05-19 16:16:28 MGR[INFO]: CPT准备就绪 type: pg cpt 2026-05-19 16:16:28 MGR[INFO]: 模块已经处于运行状态 module: link1 2026-05-19 16:16:31 link1[INFO]: 表字典加载完毕 dict num: 2, dict pool size: 0(MB) 2026-05-19 16:16:31 link1[INFO]: 表字典加载完毕 dict num: 2, dict pool size: 0(MB)

数据装载成功

image.png

评论
后发表回复

作者

文章

阅读量

获赞

扫一扫
联系客服